Use After Free Affecting irssi package, versions <1.4.2-1ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.81% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2210-IRSSI-5408499
  • published5 Apr 2023
  • disclosed14 Apr 2023

Introduced: 5 Apr 2023

CVE-2023-29132  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:22.10 irssi to version 1.4.2-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:22.10 relevant fixed versions and status.

Irssi 1.3.x and 1.4.x before 1.4.4 has a use-after-free because of use of a stale special collector reference. This occurs when printing of a non-formatted line is concurrent with printing of a formatted line.

CVSS Base Scores

version 3.1