Buffer Overflow Affecting liblouis package, versions <3.22.0-1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2304-LIBLOUIS-5466212
  • published15 Mar 2022
  • disclosed13 Mar 2022

Introduced: 13 Mar 2022

CVE-2022-26981  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.04 liblouis to version 3.22.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Ubuntu. See How to fix? for Ubuntu:23.04 relevant fixed versions and status.

Liblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).

CVSS Base Scores

version 3.1