Improper Input Validation Affecting libxtst package, versions <2:1.2.3-1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.29% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2304-LIBXTST-5484671
  • published13 Dec 2016
  • disclosed13 Dec 2016

Introduced: 13 Dec 2016

CVE-2016-7952  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.04 libxtst to version 2:1.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxtst package and not the libxtst package as distributed by Ubuntu. See How to fix? for Ubuntu:23.04 relevant fixed versions and status.

X.org libXtst before 1.2.3 allows remote X servers to cause a denial of service (infinite loop) via a reply in the (1) XRecordStartOfData, (2) XRecordEndOfData, or (3) XRecordClientDied category without a client sequence and with attached data.