Out-of-Bounds Affecting llvm-toolchain-13 package, versions <1:13.0.1-11ubuntu14.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2304-LLVMTOOLCHAIN13-5499826
  • published8 May 2023
  • disclosed5 May 2023

Introduced: 5 May 2023

CVE-2023-29932  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.04 llvm-toolchain-13 to version 1:13.0.1-11ubuntu14.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream llvm-toolchain-13 package and not the llvm-toolchain-13 package as distributed by Ubuntu. See How to fix? for Ubuntu:23.04 relevant fixed versions and status.

llvm-project commit fdbc55a5 was discovered to contain a segmentation fault via the component mlir::IROperand<mlir::OpOperand.

CVSS Base Scores

version 3.1