Out-of-bounds Read Affecting llvm-toolchain-14 package, versions <1:14.0.6-12ubuntu0.23.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2304-LLVMTOOLCHAIN14-5499799
  • published8 May 2023
  • disclosed5 May 2023

Introduced: 5 May 2023

CVE-2023-29939  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.04 llvm-toolchain-14 to version 1:14.0.6-12ubuntu0.23.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream llvm-toolchain-14 package and not the llvm-toolchain-14 package as distributed by Ubuntu. See How to fix? for Ubuntu:23.04 relevant fixed versions and status.

llvm-project commit a0138390 was discovered to contain a segmentation fault via the component mlir::spirv::TargetEnv::TargetEnv(mlir::spirv::TargetEnvAttr).

CVSS Base Scores

version 3.1