Use After Free Affecting accountsservice package, versions <23.13.9-2ubuntu2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.33% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-ACCOUNTSSERVICE-5973278
  • published28 Jun 2023
  • disclosed1 Sept 2023

Introduced: 28 Jun 2023

CVE-2023-3297  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 accountsservice to version 23.13.9-2ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream accountsservice package and not the accountsservice package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

In Ubuntu's accountsservice an unprivileged local attacker can trigger a use-after-free vulnerability in accountsservice by sending a D-Bus message to the accounts-daemon process.

CVSS Base Scores

version 3.1