Access of Uninitialized Pointer Affecting gerbv package, versions <2.9.8-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-GERBV-5972265
  • published25 Aug 2023
  • disclosed24 Aug 2023

Introduced: 24 Aug 2023

CVE-2023-4508  (opens in a new tab)
CWE-824  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 gerbv to version 2.9.8-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gerbv package and not the gerbv package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

A user able to control file input to Gerbv, between versions 2.4.0 and 2.10.0, can cause a crash and cause denial-of-service with a specially crafted Gerber RS-274X file.

CVSS Base Scores

version 3.1