CVE-2024-36472 Affecting gnome-shell package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-GNOMESHELL-7191116
  • published3 Jun 2024
  • disclosed28 May 2024

Introduced: 28 May 2024

CVE-2024-36472  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:23.10 gnome-shell.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-shell package and not the gnome-shell package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

In GNOME Shell through 45.7, a portal helper can be launched automatically (without user confirmation) based on network responses provided by an adversary (e.g., an adversary who controls the local Wi-Fi network), and subsequently loads untrusted JavaScript code, which may lead to resource consumption or other impacts depending on the JavaScript code's behavior.

CVSS Base Scores

version 3.1