CVE-2022-48624 Affecting less package, versions <590-2ubuntu0.23.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.06% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-LESS-6252795
  • published13 Mar 2024
  • disclosed19 Feb 2024

Introduced: 19 Feb 2024

CVE-2022-48624  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 less to version 590-2ubuntu0.23.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream less package and not the less package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

close_altfile in filename.c in less before 606 omits shell_quote calls for LESSCLOSE.

CVSS Base Scores

version 3.1