CVE-2023-49460 Affecting libheif package, versions <1.16.2-2ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.76% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-LIBHEIF-6114205
  • published26 Jun 2024
  • disclosed7 Dec 2023

Introduced: 7 Dec 2023

CVE-2023-49460  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 libheif to version 1.16.2-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libheif package and not the libheif package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

libheif v1.17.5 was discovered to contain a segmentation violation via the function UncompressedImageCodec::decode_uncompressed_image.

CVSS Base Scores

version 3.1