NULL Pointer Dereference Affecting nvidia-graphics-drivers-525-server package, versions <525.147.05-0ubuntu0.23.10.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-NVIDIAGRAPHICSDRIVERS525SERVER-6050991
  • published8 Nov 2023
  • disclosed2 Nov 2023

Introduced: 2 Nov 2023

CVE-2023-31018  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 nvidia-graphics-drivers-525-server to version 525.147.05-0ubuntu0.23.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-graphics-drivers-525-server package and not the nvidia-graphics-drivers-525-server package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

NVIDIA GPU Driver for Windows and Linux contains a vulnerability in the kernel mode layer, where an unprivileged regular user can cause a NULL-pointer dereference, which may lead to denial of service.

CVSS Base Scores

version 3.1