Out-of-bounds Write Affecting procps package, versions <2:4.0.3-1ubuntu1.23.10.1


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2310-PROCPS-5972730
  • published3 Aug 2023
  • disclosed2 Aug 2023

Introduced: 2 Aug 2023

CVE-2023-4016  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:23.10 procps to version 2:4.0.3-1ubuntu1.23.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream procps package and not the procps package as distributed by Ubuntu. See How to fix? for Ubuntu:23.10 relevant fixed versions and status.

Under some circumstances, this weakness allows a user who has access to run the “ps” utility on a machine, the ability to write almost unlimited amounts of unfiltered data into the process heap.

CVSS Base Scores

version 3.1