CVE-2026-23868 Affecting giflib package, versions <5.2.2-1ubuntu1.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-GIFLIB-15460483
  • published20 Apr 2026
  • disclosed10 Mar 2026

Introduced: 10 Mar 2026

CVE-2026-23868  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 giflib to version 5.2.2-1ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

Giflib contains a double-free vulnerability that is the result of a shallow copy in GifMakeSavedImage and incorrect error handling. The conditions needed to trigger this vulnerability are difficult but may be possible.

CVSS Base Scores

version 3.1