CVE-2023-49568 Affecting golang-github-go-git-go-git package, versions <5.4.2-4ubuntu0.24.04.3+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.7% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-GOLANGGITHUBGOGITGOGIT-6696783
  • published14 Mar 2026
  • disclosed12 Jan 2024

Introduced: 12 Jan 2024

CVE-2023-49568  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 golang-github-go-git-go-git to version 5.4.2-4ubuntu0.24.04.3+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-github-go-git-go-git package and not the golang-github-go-git-go-git package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.11. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients.

Applications using only the in-memory filesystem supported by go-git are not affected by this vulnerability. This is a go-git implementation issue and does not affect the upstream git cli.

CVSS Base Scores

version 3.1