CVE-2026-34177 Affecting incus package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-INCUS-16008858
  • published24 Apr 2026
  • disclosed9 Apr 2026

Introduced: 9 Apr 2026

CVE-2026-34177  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:24.04 incus.

NVD Description

Note: Versions mentioned in the description apply only to the upstream incus package and not the incus package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

Canonical LXD versions 4.12 through 6.7 contain an incomplete denylist in isVMLowLevelOptionForbidden (lxd/project/limits/permissions.go), which omits raw.apparmor and raw.qemu.conf from the set of keys blocked under the restricted.virtual-machines.lowlevel=block project restriction. A remote attacker with can_edit permission on a VM instance in a restricted project can inject an AppArmor rule and a QEMU chardev configuration that bridges the LXD Unix socket into the guest VM, enabling privilege escalation to LXD cluster administrator and subsequently to host root.