CVE-2024-6714 Affecting provd package, versions <0.1.2+24.04


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-PROVD-7554673
  • published24 Jul 2024
  • disclosed23 Jul 2024

Introduced: 23 Jul 2024

CVE-2024-6714  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 provd to version 0.1.2+24.04 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream provd package and not the provd package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

An issue was discovered in provd before version 0.1.5 with a setuid binary, which allows a local attacker to escalate their privilege.

CVSS Base Scores

version 3.1