Interpretation Conflict Affecting ruby-rack package, versions <2.2.7-1ubuntu0.7


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-RUBYRACK-15926537
  • published16 Apr 2026
  • disclosed2 Apr 2026

Introduced: 2 Apr 2026

CVE-2026-26961  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 ruby-rack to version 2.2.7-1ubuntu0.7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from multipart/form-data using a greedy regular expression. When a Content-Type header contains multiple boundary parameters, Rack selects the last one rather than the first. In deployments where an upstream proxy, WAF, or intermediary interprets the first boundary parameter, this mismatch can allow an attacker to smuggle multipart content past upstream inspection and have Rack parse a different body structure than the intermediary validated. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

CVSS Base Scores

version 3.1