Resource Exhaustion Affecting ruby-rack package, versions <2.2.7-1ubuntu0.7


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-RUBYRACK-15926767
  • published16 Apr 2026
  • disclosed2 Apr 2026

Introduced: 2 Apr 2026

CVE-2026-34230  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-407  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 ruby-rack to version 2.2.7-1ubuntu0.7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.select_best_encoding processes Accept-Encoding values with quadratic time complexity when the header contains many wildcard (*) entries. Because this method is used by Rack::Deflater to choose a response encoding, an unauthenticated attacker can send a single request with a crafted Accept-Encoding header and cause disproportionate CPU consumption on the compression middleware path. This results in a denial of service condition for applications using Rack::Deflater. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

CVSS Base Scores

version 3.1