Incorrect Authorization Affecting strongswan package, versions <5.9.13-2ubuntu4.24.04.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-STRONGSWAN-19653836
  • published21 Sept 2026
  • disclosed11 Sept 2026

Introduced: 11 Sep 2026

CVE-2026-78134  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 strongswan to version 5.9.13-2ubuntu4.24.04.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

strongSwan 4.5.0 through 6.0.7 has Incorrect Access Control in the eap-ttls and eap-peap plugins because there can be a missing or mismatched inner EAP identity.

CVSS Base Scores

version 3.1