Buffer Underflow Affecting vim package, versions <2:9.1.0016-1ubuntu7.10


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2404-VIM-15370429
  • published20 Mar 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2026-28419  (opens in a new tab)
CWE-124  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.04 vim to version 2:9.1.0016-1ubuntu7.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:24.04 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to version 9.2.0075, a heap-based buffer underflow exists in Vim's Emacs-style tags file parsing logic. When processing a malformed tags file where a delimiter appears at the start of a line, Vim attempts to read memory immediately preceding the allocated buffer. Version 9.2.0075 fixes the issue.

CVSS Base Scores

version 3.1