Resource Exhaustion Affecting gedit package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.33% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2410-GEDIT-8215741
  • published15 Oct 2024
  • disclosed5 Sept 2017

Introduced: 5 Sep 2017

CVE-2017-14108  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:24.10 gedit.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gedit package and not the gedit package as distributed by Ubuntu. See How to fix? for Ubuntu:24.10 relevant fixed versions and status.

libgedit.a in GNOME gedit through 3.22.1 allows remote attackers to cause a denial of service (CPU consumption) via a file that begins with many '\0' characters.