Resource Exhaustion Affecting node-ini package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.66% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2410-NODEINI-8205886
  • published15 Oct 2024
  • disclosed11 Dec 2020

Introduced: 11 Dec 2020

CVE-2020-7788  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:24.10 node-ini.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-ini package and not the node-ini package as distributed by Ubuntu. See How to fix? for Ubuntu:24.10 relevant fixed versions and status.

This affects the package ini before 1.3.6. If an attacker submits a malicious INI file to an application that parses it with ini.parse, they will pollute the prototype on the application. This can be exploited further depending on the context.

CVSS Base Scores

version 3.1