Return of Wrong Status Code Affecting pam-pkcs11 package, versions <0.6.12-2ubuntu0.24.10.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2410-PAMPKCS11-8689876
  • published24 Feb 2025
  • disclosed16 Jan 2026

Introduced: 24 Feb 2025

CVE-2025-24531  (opens in a new tab)
CWE-393  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.10 pam-pkcs11 to version 0.6.12-2ubuntu0.24.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-pkcs11 package and not the pam-pkcs11 package as distributed by Ubuntu. See How to fix? for Ubuntu:24.10 relevant fixed versions and status.

In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in many error situations (such as an error triggered by a smartcard before login), allowing authentication bypass.

CVSS Base Scores

version 3.1