CVE-2021-28117 Affecting plasma-discover package, versions <5.21.3-0ubuntu1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.56% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2410-PLASMADISCOVER-8201815
  • published15 Oct 2024
  • disclosed20 Mar 2021

Introduced: 20 Mar 2021

CVE-2021-28117  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.10 plasma-discover to version 5.21.3-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream plasma-discover package and not the plasma-discover package as distributed by Ubuntu. See How to fix? for Ubuntu:24.10 relevant fixed versions and status.

libdiscover/backends/KNSBackend/KNSResource.cpp in KDE Discover before 5.21.3 automatically creates links to potentially dangerous URLs (that are neither https:// nor http://) based on the content of the store.kde.org web site. (5.18.7 is also a fixed version.)

CVSS Base Scores

version 3.1