CVE-2024-1141 Affecting python-glance-store package, versions <4.6.1-0ubuntu3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2410-PYTHONGLANCESTORE-8193882
  • published15 Oct 2024
  • disclosed1 Feb 2024

Introduced: 1 Feb 2024

CVE-2024-1141  (opens in a new tab)

How to fix?

Upgrade Ubuntu:24.10 python-glance-store to version 4.6.1-0ubuntu3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-glance-store package and not the python-glance-store package as distributed by Ubuntu. See How to fix? for Ubuntu:24.10 relevant fixed versions and status.

A vulnerability was found in python-glance-store. The issue occurs when the package logs the access_key for the glance-store when the DEBUG log level is enabled.

CVSS Base Scores

version 3.1