Integer Overflow or Wraparound Affecting glib2.0 package, versions <2.84.1-1ubuntu0.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.52% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2504-GLIB20-10363288
  • published4 Jul 2025
  • disclosed13 Jun 2025

Introduced: 13 Jun 2025

CVE-2025-6052  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.04 glib2.0 to version 2.84.1-1ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glib2.0 package and not the glib2.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:25.04 relevant fixed versions and status.

A flaw was found in how GLib’s GString manages memory when adding data to strings. If a string is already very large, combining it with more input can cause a hidden overflow in the size calculation. This makes the system think it has enough memory when it doesn’t. As a result, data may be written past the end of the allocated memory, leading to crashes or memory corruption.

CVSS Base Scores

version 3.1