Heap-based Buffer Overflow Affecting gnuplot package, versions <6.0.2+dfsg1-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.21% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2504-GNUPLOT-9789713
  • published14 Jun 2025
  • disclosed7 May 2025

Introduced: 7 May 2025

CVE-2025-31177  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.04 gnuplot to version 6.0.2+dfsg1-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnuplot package and not the gnuplot package as distributed by Ubuntu. See How to fix? for Ubuntu:25.04 relevant fixed versions and status.

gnuplot is affected by a heap buffer overflow at function utf8_copy_one.

CVSS Base Scores

version 3.1