Integer Underflow Affecting strongswan package, versions <5.9.13-2ubuntu4.25.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.98% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2504-STRONGSWAN-13842362
  • published6 Nov 2025
  • disclosed16 Jan 2026

Introduced: 6 Nov 2025

CVE-2025-62291  (opens in a new tab)
CWE-191  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.04 strongswan to version 5.9.13-2ubuntu4.25.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Ubuntu. See How to fix? for Ubuntu:25.04 relevant fixed versions and status.

In the eap-mschapv2 plugin (client-side) in strongSwan before 6.0.3, a malicious EAP-MSCHAPv2 server can send a crafted message of size 6 through 8, and cause an integer underflow that potentially results in a heap-based buffer overflow.

CVSS Base Scores

version 3.1