CVE-2021-27291 The advisory has been revoked - it doesn't affect any version of package eric  (opens in a new tab)


Threat Intelligence

EPSS
3.91% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-ERIC-15025151
  • published17 Jan 2026
  • disclosed17 Mar 2021

Introduced: 17 Mar 2021

CVE-2021-27291  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:25.10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream eric package and not the eric package as distributed by Ubuntu.

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.