Memory Leak Affecting freeglut package, versions <3.4.0-5ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.15% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-FREEGLUT-14048105
  • published19 Nov 2025
  • disclosed5 Feb 2024

Introduced: 5 Feb 2024

CVE-2024-24258  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 freeglut to version 3.4.0-5ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeglut package and not the freeglut package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

freeglut 3.4.0 was discovered to contain a memory leak via the menuEntry variable in the glutAddSubMenu function.

CVSS Base Scores

version 3.1