Improper Handling of Length Parameter Inconsistency Affecting haproxy package, versions <3.0.12-0ubuntu0.25.10.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.48% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-HAPROXY-15356445
  • published26 Feb 2026
  • disclosed20 Jul 2026

Introduced: 26 Feb 2026

CVE-2026-26081  (opens in a new tab)
CWE-130  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 haproxy to version 3.0.12-0ubuntu0.25.10.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy package and not the haproxy package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

HAProxy Community Edition 3.0 through 3.3 before 3.3.3 lacks a length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected.

CVSS Base Scores

version 3.1