SQL Injection Affecting hoteldruid package, versions <2.3.2-1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.64% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-HOTELDRUID-15444937
  • published10 Mar 2026
  • disclosed7 Jun 2019

Introduced: 7 Jun 2019

CVE-2019-9087  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 hoteldruid to version 2.3.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hoteldruid package and not the hoteldruid package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

HotelDruid before v2.3.1 has SQL Injection via the /tab_tariffe.php numtariffa1 parameter.