Expired Pointer Dereference Affecting libxml2 package, versions <2.14.5+dfsg-0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.59% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-LIBXML2-14114558
  • published26 Nov 2025
  • disclosed16 Jun 2025

Introduced: 16 Jun 2025

CVE-2025-49795  (opens in a new tab)
CWE-825  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 libxml2 to version 2.14.5+dfsg-0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

A NULL pointer dereference vulnerability was found in libxml2 when processing XPath XML expressions. This flaw allows an attacker to craft a malicious XML input to libxml2, leading to a denial of service.

CVSS Base Scores

version 3.1