Access of Resource Using Incompatible Type ('Type Confusion') Affecting libxml2 package, versions <2.14.5+dfsg-0.2ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.63% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-LIBXML2-16238342
  • published20 Jun 2026
  • disclosed23 Apr 2026

Introduced: 23 Apr 2026

CVE-2026-6732  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 libxml2 to version 2.14.5+dfsg-0.2ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

A flaw was found in libxml2. This vulnerability occurs when the library processes a specially crafted XML Schema Definition (XSD) validated document that includes an internal entity reference. An attacker could exploit this by providing a malicious document, leading to a type confusion error that causes the application to crash. This results in a denial of service (DoS), making the affected system or application unavailable.

CVSS Base Scores

version 3.1