Arbitrary Code Injection Affecting ruby-kramdown package, versions <2.3.0-4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.56% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-RUBYKRAMDOWN-15732252
  • published21 Mar 2026
  • disclosed17 Jul 2020

Introduced: 17 Jul 2020

CVE-2020-14001  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 ruby-kramdown to version 2.3.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-kramdown package and not the ruby-kramdown package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.

CVSS Base Scores

version 3.1