OS Command Injection Affecting vim package, versions <2:9.1.0967-1ubuntu6.6


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.55% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-VIM-16781824
  • published3 Jun 2026
  • disclosed15 May 2026

Introduced: 15 May 2026

CVE-2026-46483  (opens in a new tab)
CWE-78  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 vim to version 2:9.1.0967-1ubuntu6.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to 9.2.0479, a command injection vulnerability exists in tar#Vimuntar() in runtime/autoload/tar.vim when decompressing .tgz archives on Unix-like systems. The function builds :!gunzip and :!gzip -d commands using shellescape(tartail) without the {special} flag, allowing a crafted archive filename to trigger Vim cmdline-special expansion and execute shell commands in the user's context. This vulnerability is fixed in 9.2.0479.

CVSS Base Scores

version 3.1