OS Command Injection Affecting vim package, versions <2:9.1.0967-1ubuntu6.8


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.23% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2510-VIM-17534174
  • published1 Jul 2026
  • disclosed25 Jun 2026

Introduced: 25 Jun 2026

CVE-2026-55895  (opens in a new tab)
CWE-78  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:25.10 vim to version 2:9.1.0967-1ubuntu6.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:25.10 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to 9.2.0663, a Vimscript code injection vulnerability exists in s:NetrwLocalRmFile() in the netrw plugin (runtime/pack/dist/opt/netrw/autoload/netrw.vim) when deleting a local file from the browser. A filename derived from the buffer's directory listing is interpolated into an Ex command line passed to :execute with only the backslash character escaped, allowing a crafted filename containing a bar (|) to terminate the intended command and execute arbitrary Vimscript, including shell commands via :call system() and :!. This vulnerability is fixed in 9.2.0663.

CVSS Base Scores

version 3.1