CVE-2026-56210 Affecting aom package, versions <3.13.1-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.58% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-AOM-17398342
  • published16 Sept 2026
  • disclosed19 Jun 2026

Introduced: 19 Jun 2026

CVE-2026-56210  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 aom to version 3.13.1-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aom package and not the aom package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A heap-buffer-overflow read vulnerability was found in libaom, the reference AV1 codec implementation. A missing bounds check in the SVC (Scalable Video Coding) layer ID control function allows setting a spatial_layer_id exceeding the configured number of layers. This causes an out-of-bounds heap read of approximately 40,728 bytes when computing a layer context array index. An attacker who can influence SVC encoder parameters in a network-facing service could exploit this for information disclosure (heap content leak) or denial of service (segmentation fault from hitting unmapped memory).

References

CVSS Base Scores

version 3.1