Heap-based Buffer Overflow Affecting biosig package, versions <3.9.0-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.59% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-BIOSIG-16235363
  • published2 Sept 2026
  • disclosed3 Mar 2026

Introduced: 3 Mar 2026

CVE-2026-20777  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 biosig to version 3.9.0-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream biosig package and not the biosig package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A heap-based buffer overflow vulnerability exists in the Nicolet WFT parsing functionality of The Biosig Project libbiosig 3.9.2 and Master Branch (db9a9a63). A specially crafted .wft file can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1