CVE-2025-61106 Affecting frr package, versions <10.5.1-1ubuntu2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-FRR-16232056
  • published24 Apr 2026
  • disclosed28 Oct 2025

Introduced: 28 Oct 2025

CVE-2025-61106  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 frr to version 10.5.1-1ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

FRRouting/frr from v4.0 through v10.4.1 was discovered to contain a NULL pointer dereference via the show_vty_ext_pref_pref_sid function at ospf_ext.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted OSPF packet.

CVSS Base Scores

version 3.1