CVE-2026-37457 Affecting frr package, versions <10.5.1-1ubuntu4.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-FRR-16421636
  • published4 Jun 2026
  • disclosed1 May 2026

Introduced: 1 May 2026

CVE-2026-37457  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 frr to version 10.5.1-1ubuntu4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream frr package and not the frr package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

An off-by-one out-of-bounds write vulnerability in the bgp_flowspec_op_decode() function (bgpd/bgp_flowspec_util.c) of FRRouting (FRR) stable/10.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted FlowSpec component.

CVSS Base Scores

version 3.1