Heap-based Buffer Overflow Affecting ghostscript package, versions <10.06.0~dfsg-3ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.85% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-GHOSTSCRIPT-19866339
  • published22 Sept 2026
  • disclosed15 Sept 2026

Introduced: 15 Sep 2026

CVE-2026-39919  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 ghostscript to version 10.06.0~dfsg-3ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript package and not the ghostscript package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

Ghostscript before 10.08.0 contains a heap-based buffer overflow vulnerability in the JPEG 2000 output adapter (base/sjpx_openjpeg.c) that allows attackers to cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. When image components declare different subsampling values, the non-samescale sub-byte-depth output path allocates a row buffer sized for packed output but writes a full byte per output column regardless of bit depth, overflowing the allocation and corrupting internal chunk-allocator metadata to achieve code execution.

CVSS Base Scores

version 3.1