Out-of-bounds Read Affecting hivex package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.85% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-HIVEX-16214147
  • published24 Apr 2026
  • disclosed11 May 2021

Introduced: 11 May 2021

CVE-2021-3504  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:26.04 hivex.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hivex package and not the hivex package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A flaw was found in the hivex library in versions before 1.3.20. It is caused due to a lack of bounds check within the hivex_open function. An attacker could input a specially crafted Windows Registry (hive) file which would cause hivex to read memory beyond its normal bounds or cause the program to crash. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1