Integer Overflow or Wraparound Affecting hplip package, versions <3.24.4+dfsg0-0ubuntu8.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.81% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-HPLIP-17339765
  • published30 Jun 2026
  • disclosed20 May 2026

Introduced: 20 May 2026

CVE-2026-8631  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 hplip to version 3.24.4+dfsg0-0ubuntu8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hplip package and not the hplip package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A potential security vulnerability has been identified in the HP Linux Imaging and Printing Software. This potential vulnerability may allow escalation of privileges and/or arbitrary code execution via an integer overflow in the hpcups processing path when handling crafted print data.

CVSS Base Scores

version 3.1