CVE-2026-45190 Affecting libnet-cidr-lite-perl package, versions <0.22-2ubuntu0.26.04.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBNETCIDRLITEPERL-17339719
  • published18 Jun 2026
  • disclosed10 May 2026

Introduced: 10 May 2026

CVE-2026-45190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libnet-cidr-lite-perl to version 0.22-2ubuntu0.26.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnet-cidr-lite-perl package and not the libnet-cidr-lite-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

Net::CIDR::Lite versions before 0.24 for Perl does not properly validate IP address and CIDR mask inputs, which may allow IP ACL bypass.

Inputs containing a trailing newline or non-ASCII digit characters pass the validators but are then re-encoded by the parser to a different address than the input string spelled. find() and bin_find() can match or miss addresses as a result.

Example:

my $cidr = Net::CIDR::Lite->new(); $cidr->add("::1\n/128"); $cidr->find("::1a"); # incorrectly returns true

See also CVE-2026-45191.

CVSS Base Scores

version 3.1