Buffer Access with Incorrect Length Value Affecting libsoup3 package, versions <3.6.6-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBSOUP3-17427566
  • published22 Oct 2026
  • disclosed22 Jun 2026

Introduced: 22 Jun 2026

CVE-2026-12549  (opens in a new tab)
CWE-805  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libsoup3 to version 3.6.6-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsoup3 package and not the libsoup3 package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

The fix for CVE-2026-2443 was regressed by a subsequent rework commit that replaced specific overflow checks with a general signed comparison. When a client sends a Range request with a suffix length exceeding the content size, the resulting negative start value is not properly clamped, leading to malformed HTTP 206 responses and log flooding.

CVSS Base Scores

version 3.1