Heap-based Buffer Overflow Affecting libxfont package, versions <1:2.0.6-2ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.39% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBXFONT-17910203
  • published21 Jul 2026
  • disclosed8 Jul 2026

Introduced: 8 Jul 2026

CVE-2026-56001  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libxfont to version 1:2.0.6-2ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxfont package and not the libxfont package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A heap buffer overflow in BitmapScaleBitmaps in libXfont2 before 2.0.8 due to an overflowing 32bit size could be used by attackers able to access the X Server to execute code within the X server cont

CVSS Base Scores

version 3.1