Access of Resource Using Incompatible Type ('Type Confusion') Affecting libxml2 package, versions <2.15.2+dfsg-0.1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.63% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBXML2-16238343
  • published20 Jun 2026
  • disclosed23 Apr 2026

Introduced: 23 Apr 2026

CVE-2026-6732  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libxml2 to version 2.15.2+dfsg-0.1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

A flaw was found in libxml2. This vulnerability occurs when the library processes a specially crafted XML Schema Definition (XSD) validated document that includes an internal entity reference. An attacker could exploit this by providing a malicious document, leading to a type confusion error that causes the application to crash. This results in a denial of service (DoS), making the affected system or application unavailable.

CVSS Base Scores

version 3.1