Integer Coercion Error Affecting libxml2 package, versions <2.15.2+dfsg-0.1ubuntu0.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBXML2-19638466
  • published9 Oct 2026
  • disclosed5 Sept 2026

Introduced: 5 Sep 2026

CVE-2026-86143  (opens in a new tab)
CWE-192  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libxml2 to version 2.15.2+dfsg-0.1ubuntu0.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2 package and not the libxml2 package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

In xmlIO in libxml2 before 2.15.4, an inconsistency in xmlOutputWriteCallback and xmlBufUse causes negative lengths to reach write callbacks, aka a lack of a check for integer overflow before calling writecallback. This has security relevance for many types of uses of that length value within a callback.

CVSS Base Scores

version 3.1