Buffer Over-read Affecting libxtst package, versions <2:1.2.5-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.2% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2604-LIBXTST-20267346
  • published15 Oct 2026
  • disclosed28 Sept 2026

Introduced: 28 Sep 2026

CVE-2026-94286  (opens in a new tab)
CWE-126  (opens in a new tab)

How to fix?

Upgrade Ubuntu:26.04 libxtst to version 2:1.2.5-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxtst package and not the libxtst package as distributed by Ubuntu. See How to fix? for Ubuntu:26.04 relevant fixed versions and status.

An out-of-bounds read in libXtst's RECORD reply parser in libXtst before 1.2.6 could be used by malicious X servers to crash attached X clients.

CVSS Base Scores

version 3.1